SEO Onpage Optimierung mit Excel (SEO Campixx 2014)

download SEO Onpage Optimierung mit Excel (SEO Campixx 2014)

of 47

Embed Size (px)

description

 

Transcript of SEO Onpage Optimierung mit Excel (SEO Campixx 2014)

  • 1. SEO Onpage Optimierung mit Excel
  • 2. 2 Stephan Walcher Seit 2006 im Bereich SEO aktiv SEO in Sdtirol mit Schwerpunkt Tourimus Ex-Bing und Inhouse SEO fr MSN.de Seit 2011 bei Catbird Seat / Head of SEO Consulting #Geek #Nerd #WindowsPhone #Windows8 Links: Blog http://www.prometeo.de Twitter http://twitter.com/stephanw Follow me on Twitter: @StephanW
  • 3. 3 FIONA! Mehr von Fiona auf: http://instagram.com/fiona_cbs
  • 4. SEO Onpage Optimierung mit Excel
  • 5. 5 Daten, Daten, Daten und ach ja DATEN! Follow me on Twitter: @StephanW
  • 6. 6 Daten sammeln Crawler SEO Screaming Frog Xenu Online Tools Google Analytics Google Webmaster Tools Bing Webmaster Tools Link Research Tools Reports Searchmetrics Sistrix Onpage.org SEOratio Strucr Ahrefs Majestic SEO Advanced Web Ranking Cloud Ntzliche URL basierte Datenquellen Follow me on Twitter: @StephanW Egal ob Social Interactions, Backlinks, interner PageRank, DomainPop usw. alles basiert auf URL. URLs sind DER gemeinsame Nenner aller Tool Anbieter
  • 7. 7 Daten sammeln Umsonst Aktuelle Version vom September 2010 Sehr schnell, auch bei groen Seiten Wenig Zustzliche Informationen Generiert einfache URL Listen Ist im Grunde nur ein 404 Broken Link Tool Xenus Link Sleuth Follow me on Twitter: @StephanW
  • 8. 8 Daten sammeln SEO Screaming Frog Follow me on Twitter: @StephanW Fr Windows, Mac oder Ubuntu verfgbar Basiert auf Java Gratisversion erlaubt max. 500 URLs zu crawlen - 99/Jahr ohne VAT Beliebig viele Crawls User-Agent frei definierbar Liefert zahlreiche Fehlerlisten 30X redirects 404/50X Duplicate Pages (Hash Wert) Meta Description (nicht vorhanden, zu lang, usw) H1/H2 (nicht vorhanden, zu lange, multiple) Canonicals (nicht vorhanden) Meta Robots (noindex, nofollow usw.) In- und Outlinks Anchor Text Weiterleitungsketten Usw.
  • 9. 9 Probe Crawl Setup SessionIDs Tracking Custom Code Vollstndiger Scan Data Matching Pivot Analyse & Report Daten sammeln Crawling richtig gemacht Experten Tipp Beim Crawl am besten immer prfen ob Tracking Codes oder IVW Pixel vorhanden sind Follow me on Twitter: @StephanW
  • 10. 10 Follow me on Twitter: @StephanW Martin Tauber Content Inventur mit dem SEO Screaming Frog Heute: 11:45 Raum:
  • 11. 11 Daten sammeln - Export Follow me on Twitter: @StephanW EXPORT
  • 12. 12 Daten sammeln - Import Follow me on Twitter: @StephanW Beim Import immer UTF-8 verwenden
  • 13. 13 Daten sammeln - Output Follow me on Twitter: @StephanW Bei eine zu hohen Anzahl von URLs (max 1. Mio): Nur HTMLs URLs exportieren
  • 14. 14 Data Matching
  • 15. 15 Follow me on Twitter: @StephanW Data Matching Ursprnglicher Name Microsoft Multiplan (Mac) - 1985 Seit 1988 auch fr Windows 2.x Runtime Aktuelle Version Excel 2013 (Windows) und Excel 2011 (Mac) Excel kann seit Excel 2007 mit mehr als 65.000 Zeilen umgehen Zahlreiche Erweiterungen und AddIns Power Pivot Bing Ads Intelligence SEO Toosl Niels Bosma ASAP Utilities Microsoft Excel http://de.excel-translator.de/infos/ Keine englischen Formeln im deutschen Excel
  • 16. 16 Data Matching Excel Funktionen Wenn() Gibt einen bestimmten Wert zurck, wenn die angegebene Bedingung WAHR ist z.B. bei Ranking Positionen >> Top10 Ja/Nein SummWenn() Summiert die Werte einer Spalte, wenn eine Bedingung eintrifft z.B. Anzahl von Backlinks fr ein bestimmtes Verzeichnis SummeWenns() Summiert die Werte einer Spalte, wenn mehre Bedingungen eintreffen Sortieren Sortiert die Werte in einer Spalte Auf- und Abwrts z.B. sehr ntzlich beim SVERWEIS() Gleichheitszeichen Vergleicht zwei Zellen miteinander ob diese identisch sind z.B. Canonical-tag berprfung UrlProperty() Extrahiert Eigenschaften aus einer URL (SEO Tools for Excel) z.B. Host oder Domain Weitere wichtige und ntzliche Excel Funktionen Follow me on Twitter: @StephanW
  • 17. SVERWEIS() vs. INDEX() =SVERWEIS(Suchkriterium;Matrix;Spalteni ndex;Bereich_Verweis) Sucht in der uersten linken Spalte einer Tabelle nach einem Wert und gibt den entsprechenden Wert in einer anderen Spalte wieder Sverweis = SpaltenVERWEIS z.B. Crawl Daten (Tabelle1) mit Google Analytics (Tabelle2) matchen# Suchkriterium: URL Matrix: Tabelle2 SpaltenIndex: In Welcher Spalte stehen die Visits? Bereich:Verweis: Falsch = Genauer Treffer =INDEX(Matrix;Zeile;Spalte) + =VERGLEICH() Kann einen Wert in einer beliebigen Spalte suchen und einen Wert aus einer anderen Spalte wiedergeben. Sehr Rechenintensiv Daten matching ohne Spaltenverschiebung Data Matching Excel Funktionen Follow me on Twitter: @StephanW =Wennfehler() vermeidet das hssliche #NA
  • 18. Sverweis() vs. Index() =SVERWEIS(Suchkriterium;Matrix;Spalteni ndex;Bereich_Verweis) =INDEX(Matrix;Zeile;Spalte) + =VERGLEICH() Data Matching Excel Funktionen Follow me on Twitter: @StephanW =INDEX($A$1:$B$11;VERGLEICH(D2;$B$1:$ B$11;0);VERGLEICH($E$1;$1:$1;0)) =WENNFEHLER(SVERWEIS(D2;A1:B6;2;FAL SCH);"") Sverweis Gibt immer den ersten Wert wieder, der gefunden wird
  • 19. 19 Data Matching Excel Funktionen =Verketten() s. Google Analytics Content Export Follow me on Twitter: @StephanW
  • 20. 20 Excel Formeln im Einsatz Level: Basic
  • 21. 21 Excel Formeln im Einsatz Gleichheitszeichen Follow me on Twitter: @StephanW A2=B2
  • 22. 22 Excel Formeln im Einsatz Gleichheitszeichen + Wenn-Funktion Follow me on Twitter: @StephanW =WENN(S2="";"kein Canonical";WENN(A2=S2;"Canonical auf sich selbst (unique)";"Canonical auf andere Seite (DC)")) Wenn Canonical-Feld (S2) leer, dann schreib Kein Canonical. Wenn URL(A2)=Canonical(S2) dann schreib Canonical auf sich selbst. Wenn nichts zutrifft Canonical auf andere Seite
  • 23. 23 Excel Formeln im Einsatz UrlProperty()* Follow me on Twitter: @StephanW =UrlProperty(D2;"Domain") *SEO Tools for Excel
  • 24. 24 Excel Formeln im Einsatz Wrter zhlen Follow me on Twitter: @StephanW =WENN(LNGE(GLTTEN(K6))=0;0;LNGE(GLTTEN(K6))-LNGE(WECHSELN(K6;" ";""))+1)
  • 25. 25 Excel Formeln im Einsatz Level: Advanced
  • 26. 26 Excel Formeln im Einsatz - Advanced Follow me on Twitter: @StephanW Back to school - Mengenlehre 2 3 5 1 4 6 8 10 12 2 3 5 1 4 6 8 10 12 2 3 5 1 4 6 8 10 12 A B A B A B A B A B A U B
  • 27.