Übung 6 ACL EIGRP - htlganzeinfach.at fileEs ist das Routingprotokoll EIGRP zu verwenden. Es soll...

of 14 /14
Übung 5 – ACL/EIGRP 9. Januar 2014 Seite 1 von 14 TROJKÓ, ÖZHOROZ Inventar / Geräteliste Allgemeine Bezeichnung Hersteller Typ Zusätzliche Informationen Notebook Dell Inspiron Packet Tracer 5.3.1.0044 Notebook Macintosh MacBook Packet Tracer 5.3.1.0044 Laborübungen NWTK Informationstechnologie für Berufstätige Höhere technische Bundeslehranstalt, 1160 Wien, Thaliastraße 125 Klasse 5ABKIF Gruppenleiter - Projektbeginn 18.15 – 19.12.2013 Projektteilnehmer Trojkó - Katalognummer: 11 Özhoroz - Katalognummer: 5 Projektende 21.30 – 19.12.2013 Abgabe 09.01.2014 Projekttitel ! Übung 5 für ACL/EIGRP Projektbetreuer Hr. Zeiler Signum des Betreuers

Embed Size (px)

Transcript of Übung 6 ACL EIGRP - htlganzeinfach.at fileEs ist das Routingprotokoll EIGRP zu verwenden. Es soll...

bung 5 ACL/EIGRP 9. Januar 2014

Seite 1 von 14 TROJK, ZHOROZ

Inventar / Gerteliste Allgemeine Bezeichnung

Hersteller Typ Zustzliche Informationen

Notebook Dell Inspiron Packet Tracer 5.3.1.0044

Notebook Macintosh MacBook Packet Tracer 5.3.1.0044

Laborbungen NWTK Informationstechnologie fr Berufsttige

Hhere technische Bundeslehranstalt, 1160 Wien, Thaliastrae 125

Klasse

5ABKIF

Gruppenleiter

-

Projektbeginn

18.15 19.12.2013

Projektteilnehmer

Trojk - Katalognummer: 11

zhoroz - Katalognummer: 5

Projektende

21.30 19.12.2013 Abgabe 09.01.2014

Projekttitel

! bung 5 fr ACL/EIGRP

Projektbetreuer

Hr. Zeiler

Signum des Betreuers

bung 5 ACL/EIGRP 9. Januar 2014

Seite 2 von 14 TROJK, ZHOROZ

Inhaltsverzeichnis Deckblatt ............................................................................................................................................ 1

Gerteliste .......................................................................................................................................... 1

Aufgabenstellung ................................................................................................................................ 3

Schnittstellentabelle ........................................................................................................................... 5

Router Konfiguration. ......................................................................................................................... 6

DHCP Konfiguration ........................................................................................................................... 7

EIGRP Konfiguration. ......................................................................................................................... 7

Access List ....................................................................................................................................... 10

Einstellungen speichern ................................................................................................................... 11

Webserver Konfiguration .................................................................................................................. 11

bung 5 ACL/EIGRP 9. Januar 2014

Seite 3 von 14 TROJK, ZHOROZ

bung 5 NWTK: ACL/EIGRP

Fr zwei Standorte (Standort 1: Zentrale - 7 Arbeitspltze; Standort 2: Verkaufslokation - 3 Arbeitspltze) soll die Netzwerkinfrastruktur geplant und erstellt werden. Es ist das Routingprotokoll EIGRP zu verwenden.

Es soll von Standort 2 nach Standort 1 bzw. von Standort 1 nach Standort 2

TFTP nur am eigenen Standort erlaubt, jedoch nicht vom anderen Standort WWW erlaubt (Test via Intranetserver) ICMP erlaubt (Test via PING)

sein.

Die Arbeitsstationen sollen die IP-Adressen via DHCP zugewiesen bekommen. Verwenden sie fr DHCP die Netze 10.32+x.0.0 (x ist ein Vielfaches der Katalognummer bzw. die Katalognummer).

Die Namen der aktiven Komponenten sollen Bestandteile Ihres Familien- oder Vornamens beinhalten.

Erarbeiten Sie mit dem Tool Packet Tracer die Netzwerkinfrastruktur fr diese beiden Standorte.

Das Netz muss wie auf dem Bild 01 aufgebaut werden. Zu beachten ist, dass zwischen den Routern (gleichwertige Gerte) ein Cross-Over-Kabel zu verwenden ist.

In diesem Beispiel muss den Switches zustzlich FastEthernet-Ports eingebaut werden.

bung 5 ACL/EIGRP 9. Januar 2014

Seite 4 von 14 TROJK, ZHOROZ

Bevor die Ports eingebaut werden knnen, muss der Switch, mit dem Schalter auf der rechten des Bildes,

abgeschaltet werden. Danach werden Ports mit der Maus per drag&drop von links nach rechts in die freie

Stelle gezogen. Danach muss der Switch wieder eingeschaltet werden.

bung 5 ACL/EIGRP 9. Januar 2014

Seite 5 von 14 TROJK, ZHOROZ

Als erstes wird die IP-Konfiguration geplant. Subnetze, Router, Clients und Server.

DHCP Zentrale Verkaufslokation

Network 10.43.0.0/16 10.37.0.0/16

Subnetzmaske 255.255.0.0 255.255.0.0

Default-Router 10.43.0.1 10.37.0.1

PC0 10.43.0.2 - DHCP

PC1 10.43.0.3 - DHCP

PC2 10.43.0.4 - DHCP

PC3 10.43.0.5 - DHCP

PC4 10.43.0.6 - DHCP

PC5 10.43.0.7 - DHCP

PC6 10.43.0.8 - DHCP

PC7 10.37.0.2 - DHCP

PC8 10.37.0.3 - DHCP

PC9 10.37.0.4 - DHCP EIGRP RouterOe0zhoroz Router1Trojko AS 100

network 10.43.0.0 10.37.0.0

network 10.5.0.0 10.5.0.0 Das Netz 10.5.0.0 ist die Verbindung zwischen den beiden Routern. Server Verkaufslokation Webserver 10.37.0.50 statisch Erklrung: Hier werden auf den Routern die Schnittstellen mit den IP-Adressen aus der obigen Tabelle konfiguriert.

bung 5 ACL/EIGRP 9. Januar 2014

Seite 6 von 14 TROJK, ZHOROZ

Router0 Oezhoroz Konfiguration

Ports konfigurieren:

Router>en

Router#conf t

Router(config)#hostname Router0Oezhoroz

Router0Oezhoroz(config)#

Router0Oezhoroz(config)#interface FastEthernet0/0

Router0Oezhoroz(config-if)#ip address 10.43.0.1 255.255.0.0

Router0Oezhoroz(config-if)#no shutdown

Router0Oezhoroz(config)#interface FastEthernet1/0

Router0Oezhoroz(config-if)#ip address 10.5.0.2 255.255.0.0

Router0Oezhoroz(config-if)#no shutdown

Router1 Trojko Konfiguration

Ports konfigurieren:

Router>en

Router#conf t

Router(config)#hostname Router1Trojko

Router1Trojko(config)#

Router1Trojko(config)#interface FastEthernet0/0

Router1Trojko(config-if)#ip address 10.37.0.1 255.255.0.0

Router1Trojko(config-if)#no shutdown

Router1Trojko(config)#interface FastEthernet1/0

Router1Trojko(config-if)#ip address 10.5.0.3 255.255.0.0

Router1Trojko(config-if)#no shutdown

bung 5 ACL/EIGRP 9. Januar 2014

Seite 7 von 14 TROJK, ZHOROZ

DHCP konfigurieren:

Router0Oezhoroz(config)#ip dhcp pool subnet1

Router0Oezhoroz(dhcp-config)#network 10.43.0.0 255.255.0.0

Router0Oezhoroz(dhcp-config)#default-router 10.43.0.1

Router0Oezhoroz(dhcp-config)#ex

DHCP konfigurieren:

Router1Trojko(config)#ip dhcp pool subnet1

Router1Trojko(dhcp-config)#network 10.37.0.0 255.255.0.0

Router1Trojko(dhcp-config)#default-router 10.37.0.1

Router1Trojko(dhcp-config)#ex

Erklrung:

EIGRP ist ein Distanz-Vektor interior Routing-Protokoll. Mithilfe von EIGRP knnen die Router die Routingtabellen austauchen.

EIGRP konfigurieren:

Beide Router mssen im selben autonomen System sein: 100

Route0Oezhoroz(config)#router eigrp 100

Route0Oezhoroz(configrouter)#network 10.43.0.0

Route0Oezhoroz(configrouter)#network 10.5.0.0

Route0Oezhoroz(config-router)#ex

Route0Oezhoroz(config)#ex

Route0Oezhoroz#show ip route

bung 5 ACL/EIGRP 9. Januar 2014

Seite 8 von 14 TROJK, ZHOROZ

EIGRP konfigurieren:

Beide Router mssen im selben autonomen System sein: 100

Router1Trojko(config)#router eigrp 100

Router1Trojko(configrouter)#network 10.37.0.0

Router1Trojko(configrouter)#network 10.5.0.0

Router1Trojko(config-router)#ex

Router1Trojko(config)#ex

Router1Trojko#show ip route

Jetzt sollten alle Clients und Server zu pingen sein. Falls nicht muss nachgeprft werden.

bung 5 ACL/EIGRP 9. Januar 2014

Seite 9 von 14 TROJK, ZHOROZ

Erklrung:

Es soll von Standort 2 nach Standort 1 bzw. von Standort 1 nach Standort 2

" TFTP nur am eigenen Standort erlaubt, jedoch nicht vom anderen Standort

" WWW erlaubt (Test via Intranetserver)

" ICMP erlaubt (Test via PING) sein.

Hier werden die Access-Listen definiert. In dieser bung wird auf jedem der beiden Router jeweils eine

Access-Liste definiert. (access-list 101 und access-list 102).

ACLs knnen den Schnittstellen als eingehenden (in) oder fr den ausgehenden (out) Verkehr zugewiesen

werden. In dieser bung werden die ACLs jeweils den Schnittstellen zugewiesen, welche die Router

miteinander verbinden (Netz-ID 10.5.0.0).

WICHTIG: Zu beachten ist, dass nach anlegen und zuweisen einer ACL, alle Pakete, die den Bedingungen der ACL nicht

entsprechen blockiert werden. Es muss in die ACL auch eine Bedingung fr das Routing-Protokoll

EIGRP eingetragen werden (access-list 101 permit eigrp any any). Ansonsten wrde das Routing nicht mehr funktionieren.

Syntax: access-list 101 permit tcp 10.37.0.0 0.0.255.255 eq www any

Die erste IP-Adresse/IP-Netz ist die Quell-Adresse und die zweite zB. Any ist die Ziel-Adresse.

eq fgt einer IP-Adresse oder einem IP-Netz einen Port hinzu.

eq www - alle Pakte von diesem Netz in Verbindung mit diesem Port

eq muss direkt nach dem gewnschten IP-Netz/IP-Adresse stehen. Beachten Sie die schreibweise.

10.37.0.0 0.0.255.255 eq www any

eq www bezieht sich auf das IP-Netz und nicht auf any

10.43.0.0 0.0.255.255 any eq www

eq www bezieht sich auf any und nicht auf das IP-Netz.

bung 5 ACL/EIGRP 9. Januar 2014

Seite 10 von 14 TROJK, ZHOROZ

Access List konfigurieren: Route0Oezhoroz(config)#access-list 101 permit icmp any any

Route0Oezhoroz(config)#access-list 101 deny udp any any eq tftp

Route0Oezhoroz(config)#access-list 101 permit tcp 10.37.0.0 0.0.255.255 eq www any

Route0Oezhoroz(config)#access-list 101 permit eigrp any any

Access List konfigurieren: Router1Trojko(config)#access-list 102 permit icmp any any

Router1Trojko(config)#access-list 102 deny udp any any eq tftp

Router1Trojko(config)#access-list 102 permit tcp 10.43.0.0 0.0.255.255 any eq www

Router1Trojko(config)#access-list 102 permit eigrp any any

Erkrung:

Mit dem Befehl access-group wird die vorher definierte ACL der Schnittstelle zugewiesen.

WICHTIG: Zu beachten ist das (in) oder (out) nach der ACL Nummer.

Eine ACL muss entweder fr den in (eingehender Verkehr) oder out (ausgehender Verkehr) definiert werden.

Access List einer Schnittstelle zuweisen:

Route0Oezhoroz(config)#

Route0Oezhoroz(config)#int fa1/0

Obelix(config-if)#ip access-group 101 in

Obelix(config-if)#exit

Access List einer Schnittstelle zuweisen:

Router1Trojko(config)#

Router1Trojko(config)#int fa1/0

Router1Trojko(config-if)#ip access-group 102 in

Router1Trojko(config-if)#exit

bung 5 ACL/EIGRP 9. Januar 2014

Seite 11 von 14 TROJK, ZHOROZ

Einstellungen speichern:

Router0Oezhoroz#copy running-config startup-config

Einstellungen speichern:

Router1Trojko#copy running-config startup-config

Webserver Konfiguration:

Erklrung:

Damit es zu keinen Problemen beim kommunizieren mit dem Server kommt, wird diesem eine statische IP-Adresse gegeben.

Erklrung:

Der Webserver muss aktiviert werden. Hier wird nun eigener HTML-Code eingefgt, welcher dann spter von

einem Client ber einen Webbrowser aufgerufen werden kann.

bung 5 ACL/EIGRP 9. Januar 2014

Seite 12 von 14 TROJK, ZHOROZ

bung 5 ACL/EIGRP 9. Januar 2014

Seite 13 von 14 TROJK, ZHOROZ

TFTP aktivieren.

Wie in den ACLs definiert, knnen HTTP-Pakete gesendet und empfangen werden.

bung 5 ACL/EIGRP 9. Januar 2014

Seite 14 von 14 TROJK, ZHOROZ

Das Pingen funktioniert jetzt auch.